
  






  
  
  
  
<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.themesatribune.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="nathaniel ross, mesa city council, rhodes scholar, university of oxford, full-ride scholarship" />
<meta name="news_keywords" content="nathaniel ross, mesa city council, rhodes scholar, university of oxford, full-ride scholarship" />
<meta name="description" content="Nathaniel Ross won&rsquo;t be sitting on Mesa City Council when new members are sworn next month." />
<meta name="author" content="Tribune News Staff" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="robots" content="max-image-preview:large" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?crop=1268%2C666%2C0%2C76&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Who needs Mesa Council when you&rsquo;re a Rhodes Scholar?" />
<meta property="og:description" content="Nathaniel Ross won&rsquo;t be sitting on Mesa City Council when new members are sworn next month." />
<meta property="og:site_name" content="The Mesa Tribune" />
<meta property="og:section" content="Community" />
<meta property="fb:app_id" content="148566918492476" />
<meta property="article:publisher" content="http://www.facebook.com/EVTNow/" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?crop=1268%2C666%2C0%2C76&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@evtnow" />
<meta name="twitter:image:alt" content="Nathaniel Ross" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.d655407c2beee1a5e5788ed5c20be9d9.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.aafcf93cf41daa238a62a66cb77cee24.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.edf843f6657f7531d7073bb7bccbbcec.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/live/global/resources/styles/site.css?_dc=1664226235"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.65.2"},"crm":{"group_id":null},"content":{"id":"1ccedaf4-6b81-11ed-a47b-db3e760f6176","title":"Who needs Mesa Council when you\u2019re a Rhodes Scholar?","type":"article","published_time":"2022-12-01T07:00:00Z","tags":["nathaniel ross","mesa city council","rhodes scholar","university of oxford","full-ride scholarship"],"authors":[],"taxnonomies":{"blox_sections":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/section","items":["community"]},"blox_flags":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/flag","items":["top_story"]}},"metrics":{"image_count":1,"video_count":0,"audio_count":0,"word_count":945},"byline":"By Tribune News Staff"}},"tncms":{"google":{"ga4":"G-KLSEGE18PP","ua":"UA-200793009-1"},"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/community","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Tribune News Staff","start_hour":"00","id":"1ccedaf4-6b81-11ed-a47b-db3e760f6176","app":"editorial","ga_page":"\/community\/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":267},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.7b5fd2a1aa906214ae39b25cd6ec9283.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.ef1ae2cf9d9803199a19b009dc464018.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://prebid.voqally.com/voqally_prebid.min.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];
    
    googletag.cmd.push(function(){
        googletag.pubads().disableInitialLoad();
    });

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '1ccedaf4-6b81-11ed-a47b-db3e760f6176';
    __tnt.ads.dfp.targeting.k = ["nathaniel ross","mesa city council","rhodes scholar","university of oxford","full-ride scholarship"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.a023713b7eff47127899286dc36e1970.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.fc1a4213adeec354910108f84bf0e732.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.d45f12d51e6b121b88d52db2e387136f.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_SKIN_LR';
            
                gptAdSlots['ad-2585770'] = googletag.defineOutOfPageSlot(adUnit, 'ad-2585770').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_728x90_TOP_ROS_LEADERBOARD';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2585749'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2585749').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_728x90_BOTTOM_ROS_LEADERBOARD';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2585752'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2585752').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/ads/impressions.js?_dc=1669894521"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/ads/traffic.js?_dc=1669880121"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/ads/settings.js?_dc=1632915553"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_TOP_ARTICLE';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[728,90],[300,250]]).addSize([992, 0], [[728,90],[300,250]]).addSize([1200, 0], [[728,90],[300,250]]).build();
                gptAdSlots['ad-2585773'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-2585773').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_MID_ARTICLE';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[728,90],[300,250]]).addSize([992, 0], [[728,90],[300,250]]).addSize([1200, 0], [[728,90],[300,250]]).build();
                gptAdSlots['ad-2585776'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-2585776').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_BOT_ARTICLE';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[728,90],[300,250]]).addSize([992, 0], [[728,90],[300,250]]).addSize([1200, 0], [[728,90],[300,250]]).build();
                gptAdSlots['ad-2585779'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-2585779').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_TOP_SIDEBAR';
            
                gptAdSlots['ad-2585758'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2585758').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_MID_SIDEBAR';
            
                gptAdSlots['ad-2585761'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2585761').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x600_MID_SIDEBAR';
            
                gptAdSlots['ad-2585764'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2585764').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_300x250_BOT_SIDEBAR';
            
                gptAdSlots['ad-2585767'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2585767').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/themesatribune.com/MT_728x90_BOTTOM_ROS_FOOTER';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2585755'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2585755').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Who needs Mesa Council when you’re a Rhodes Scholar? | Community | themesatribune.com</title>  
<!-- code here -->  

            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #2e2c2c; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #000; } .fixed-nav #main-navigation { background-color: #000 !important; } #site-top-nav-container, #site-top-nav { background-color: #282828; } #site-footer-container, #site-footer { background-color: #dbd5c1; color: #100010; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #fff; } .navbar-toggle .icon-bar { background-color: #fff !important; } .navbar-toggle .sr-only-show { color: #fff !important; } #site-top-nav .list-inline>li>a { color: #999; } .asset .asset-body p, .asset #asset-content p { color: #4d4d47; } #site-header-container { background-color: #fff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #fff; } }#site-copyright a, #site-footer a { color: #100010; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #e0001a; }#site-header-container{ border-bottom: 3px solid #e0001a; }#site-footer-container{ border-top: 3px solid #e0001a; } .tnt-bg-accent { background-color: #e0001a; } a .tnt-caret-down { color: #e0001a; } .block-title .block-title-inner { border-color: #e0001a; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #e0001a; } .form-control:focus { border-bottom-color: #e0001a; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.themesatribune.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/fe4bc66e-2456-11eb-9099-e75a961dee80.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Who needs Mesa Council when you’re a Rhodes Scholar? | Community | themesatribune.com" href="http://www.themesatribune.com/search/?f=rss&amp;t=article&amp;c=community&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a7c71fa5a63ad1158170fb2c085be042.js"></script>
            

<!-- Mailchimp Popup -->  
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/0d04049df38fb8464a29c6623/6af3a2efe04fcb7ae0f130591.js");</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-KLSEGE18PP"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-KLSEGE18PP');
</script>

<!-- Google AdSense -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5561327957600357" crossorigin="anonymous"></script>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-1ccedaf4-6b81-11ed-a47b-db3e760f6176  section-community type-article infinity-disabled" data-path="/community">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.themesatribune.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.65.2&amp;townnews.content.id=1ccedaf4-6b81-11ed-a47b-db3e760f6176&amp;townnews.content.title=Who+needs+Mesa+Council+when+you%E2%80%99re+a+Rhodes+Scholar%3F&amp;townnews.content.type=article&amp;townnews.content.published_time=2022-12-01T07%3A00%3A00Z&amp;townnews.content.tags.0=nathaniel+ross&amp;townnews.content.tags.1=mesa+city+council&amp;townnews.content.tags.2=rhodes+scholar&amp;townnews.content.tags.3=university+of+oxford&amp;townnews.content.tags.4=full-ride+scholarship&amp;townnews.content.taxnonomies.blox_sections.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fsection&amp;townnews.content.taxnonomies.blox_sections.items.0=community&amp;townnews.content.taxnonomies.blox_flags.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fflag&amp;townnews.content.taxnonomies.blox_flags.items.0=top_story&amp;townnews.content.metrics.image_count=1&amp;townnews.content.metrics.video_count=0&amp;townnews.content.metrics.audio_count=0&amp;townnews.content.metrics.word_count=945&amp;townnews.content.byline=By+Tribune+News+Staff&amp;tncms.google.ga4=G-KLSEGE18PP&amp;tncms.google.ua=UA-200793009-1&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fcommunity&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Tribune+News+Staff&amp;tncms.asset.start_hour=00&amp;tncms.asset.id=1ccedaf4-6b81-11ed-a47b-db3e760f6176&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fcommunity%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=267&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.themesatribune.com/tncms/admin/editorial-asset/?edit=1ccedaf4-6b81-11ed-a47b-db3e760f6176"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1911946" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1911946" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.themesatribune.com/users/signup/?referer_url=https%253A%252F%252Fwww.themesatribune.com%252Fcommunity%252Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%252Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.themesatribune.com/users/login/?referer_url=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.themesatribune.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1911946').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.themesatribune.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.themesatribune.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.themesatribune.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1911946').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.themesatribune.com/users/logout/" id="user-logout-form-1911946"><input type="hidden" name="referer_url" value="https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community ">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://obituaries.eastvalleytribune.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-obituaries">Obituaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business/"  class="nav-link tnt-section-business ">Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/get_out/"  class="nav-link tnt-section-get-out ">Get Out</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/special_sections/"  class="nav-link tnt-section-special-sections ">Special Sections</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/recommended/"  class="nav-link tnt-section-recommended ">Recommended</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="https://www.eastvalleytribune.com/classifieds/"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds ">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.eastvalleytribune.com/classifieds/"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds">Classifieds</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://jobs.phoenix.org/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://mesatribune.column.us/place/O8N8J3yTaIkSsT0J8Hp1?step=notice-type-select"  target="_blank" rel="noopener" class="nav-link tnt-section-legals">Legals</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-nav-mobile-nav-right-below" class="tncms-region-nav"></div>
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-2585770" class="tncms-block hidden"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585770" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585770');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1941996" class="tncms-block"><div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v10.0&amp;appId=1753833131597500&amp;autoLogAppEvents=1" nonce="AXq0EZ2x"></script></div><div id="tncms-block-1940524" class="tncms-block"><style>
#main-nav_menu li:hover {
    background-color: #e0001a;
}
#main-nav_menu .dropdown-menu li:hover {
    background-color: transparent;
}
#masthead-col-one {
    float: right;
}
#masthead-col-two {
    float: left;
}
</style></div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link    tnt-section-about"  href="https://www.themesatribune.com/site/about.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">About</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="https://www.themesatribune.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">| Contact</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="https://www.themesatribune.com/site/forms/online_services/advertise_with_us/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">| Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-employment"  href="http://timespublications.com/#careers"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">| Employment </span>
                </a></li><li>
                <a class="nav-link    tnt-section-digital-editions"  href="/digital_edition/"  tabindex="0" >
                    <span class="nav-label ">| Digital Editions</span>
                </a></li><li>
                <a class="nav-link    tnt-section-e-subscribe"  href="/e-subscribe/"  tabindex="0" >
                    <span class="nav-label ">| E-Subscribe</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1912077" class="tncms-block padding-left padding-bottom"><div class="follow-links-1912077 follow-links pull-right">
    
    <section id="block-1912077" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/MesaTribune" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/evtnow" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.themesatribune.com",
  "sameAs" : ["https://www.facebook.com/MesaTribune","https://twitter.com/evtnow"]
}
</script>
<div class="clearfix"></div></div></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list"></ul></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-2585749" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585749" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585749');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1911930" class="tncms-block a"><section id="block-1911930" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=150%2C41 150w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=200%2C55 200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=225%2C62 225w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=300%2C83 300w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=400%2C110 400w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=540%2C149 540w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=640%2C176 640w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=750%2C207 750w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=990%2C273 990w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=1035%2C285 1035w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=1200%2C331 1200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=1333%2C367 1333w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=1476%2C407 1476w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/b69eddcc-80f6-11eb-b635-b3c666b499f7.jpg?resize=2008%2C553 2008w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="2744"
                height="756"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1911939" class="tncms-block"><section id="block-1911939" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/f6bfcf98-859b-11eb-b635-bb7894e10530.png?resize=150%2C48 150w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/f6bfcf98-859b-11eb-b635-bb7894e10530.png?resize=200%2C64 200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/f6bfcf98-859b-11eb-b635-bb7894e10530.png?resize=225%2C72 225w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/f6bfcf98-859b-11eb-b635-bb7894e10530.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="96"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1911941" class="tncms-block site-search"><ul id="site-search-1911941-dropdown" class="hidden-print nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1911941" aria-label="Site search" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1911941" class="site-search-form input-group default input-group-lg ">
        <label for="site-search-1911941-term" class="sr-only">Site search</label>
        <input id="site-search-1911941-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1911941-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-1911941" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div><div id="tncms-block-1911947" class="tncms-block padding-bottom"><div id="weather-1911947" class="weather-current size-nav pull-right">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=85202" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">46&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="85202">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1911947" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Mesa, AZ
                                
                                <small>(85202)</small>
                            </h4><h5>Today</h5>
                                <p>Sunshine and clouds mixed. High 73F. Winds light and variable..
                                </p>
                                <h5>Tonight</h5>
                                <p>Partly to mostly cloudy. Low around 50F. Winds light and variable.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: December 1, 2022 @ 4:21 am</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=85202"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>
</div></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a href="/" class="nav-link tnt-section-home" >Home
                </a></li><li>
                <a href="/news" class="nav-link tnt-section-news" >News
                </a></li><li class="dropdown yamm-fw community">
                <a class="dropdown-toggle nav-link tnt-section-community" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/community/" >Community
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-community-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-obituaries" href="http://obituaries.eastvalleytribune.com/"  target="_blank" rel="noopener">Obituaries</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-community-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="/business/" class="nav-link tnt-section-business" >Business
                </a></li><li>
                <a href="/opinion/" class="nav-link tnt-section-opinion" >Opinion
                </a></li><li>
                <a href="/sports" class="nav-link tnt-section-sports" >Sports
                </a></li><li>
                <a href="/get_out/" class="nav-link tnt-section-get-out" >Get Out
                </a></li><li>
                <a href="/special_sections/" class="nav-link tnt-section-special-sections" >Special Sections
                </a></li><li>
                <a href="/recommended/" class="nav-link tnt-section-recommended" >Recommended
                </a></li><li class="dropdown yamm-fw classifieds">
                <a class="dropdown-toggle nav-link tnt-section-classifieds" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="https://www.eastvalleytribune.com/classifieds/"  target="_blank" rel="noopener">Classifieds
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-https-www-eastvalleytribune-com-classifieds-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-classifieds" href="https://www.eastvalleytribune.com/classifieds/"  target="_blank" rel="noopener">Classifieds</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-jobs" href="https://jobs.phoenix.org/"  target="_blank" rel="noopener">Jobs</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-legals" href="https://mesatribune.column.us/place/O8N8J3yTaIkSsT0J8Hp1?step=notice-type-select"  target="_blank" rel="noopener">Legals</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-https-www-eastvalleytribune-com-classifieds-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-https-www-eastvalleytribune-com-classifieds-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-https-www-eastvalleytribune-com-classifieds-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li></ul>
    </div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1911942" class="tncms-block hidden-md hidden-lg"><section id="block-1911942" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1911942" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1911942" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1911942" class="site-search-form input-group default normal form-control">
        <label for="site-search-1911942-term" class="sr-only">Site search</label>
        <input id="site-search-1911942-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1911942-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-1911942" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-2585752" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585752" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585752');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-a8762f44-6b81-11ed-9d9a-a32c13cda117" class="modal fullscreen in modal-image image-default modal-a8762f44-6b81-11ed-9d9a-a32c13cda117" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=400%2C258"
                        srcset="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=150%2C97 150w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=200%2C129 200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=225%2C145 225w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=300%2C194 300w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=400%2C258 400w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=540%2C348 540w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=640%2C413 640w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=750%2C484 750w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=990%2C639 990w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1035%2C668 1035w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1200%2C774 1200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1268%2C818 1333w"
                        sizes="100vw"
                        
                        width="1268"
                        height="818"
                        alt="Nathaniel Ross"
                        class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-a8762f44-6b81-11ed-9d9a-a32c13cda117" data-target=".caption-inner-modal-image-a8762f44-6b81-11ed-9d9a-a32c13cda117">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-a8762f44-6b81-11ed-9d9a-a32c13cda117 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themesatribune.com%2Fnathaniel-ross%2Fimage_a8762f44-6b81-11ed-9d9a-a32c13cda117.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nathaniel%20Ross&via=evtnow&url=https%3A%2F%2Fwww.themesatribune.com%2Fnathaniel-ross%2Fimage_a8762f44-6b81-11ed-9d9a-a32c13cda117.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.themesatribune.com/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.themesatribune.com/tncms/asset/editorial/a8762f44-6b81-11ed-9d9a-a32c13cda117" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Mesa%20Tribune%5D%20Nathaniel%20Ross&body=https%3A%2F%2Fwww.themesatribune.com%2Fnathaniel-ross%2Fimage_a8762f44-6b81-11ed-9d9a-a32c13cda117.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a8762f44-6b81-11ed-9d9a-a32c13cda117"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.themesatribune.com/nathaniel-ross/image_a8762f44-6b81-11ed-9d9a-a32c13cda117.html', '[data-copy-inline-a8762f44-6b81-11ed-9d9a-a32c13cda117]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Image link copied to clipboard"
                    data-copy-inline-a8762f44-6b81-11ed-9d9a-a32c13cda117
                >
                    <span class="tnt-stack" title="Copy image link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-a8762f44-6b81-11ed-9d9a-a32c13cda117-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="a8762f44-6b81-11ed-9d9a-a32c13cda117" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="a8762f44-6b81-11ed-9d9a-a32c13cda117" class="save-list-a8762f44-6b81-11ed-9d9a-a32c13cda117-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="a8762f44-6b81-11ed-9d9a-a32c13cda117" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-a8762f44-6b81-11ed-9d9a-a32c13cda117 img { max-height: 606px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="asset article-default"  data-url="https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Nathaniel Ross won’t be sitting on Mesa City Council when new members are sworn next month. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?crop=1268%2C666%2C0%2C76&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="themesatribune.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" />
    <style>
                .asset-paging .direction {
                    color: #e0001a;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.themesatribune.com\/tncms\/search\/mlt\/?origin=1ccedaf4-6b81-11ed-a47b-db3e760f6176&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="asset-paging">
                <div id="paging-prev-1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="paging-link prev offset"></div>
                <div id="paging-next-1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-top-story">top story</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
    <span>Who needs Mesa Council when you’re a Rhodes Scholar?</span>
</h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By Tribune News Staff</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-12-01T00:00:00-07:00" class="tnt-date asset-date text-muted">
            Dec 1, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-12-01T00:00:00-07:00" class="tnt-date asset-date text-muted">4 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count comment-counter">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-12-01T00:00:00-07:00">
    <meta itemprop="datePublished" content="2022-12-01T00:00:00-07:00">
    <meta itemprop="dateModified" content="2022-12-01T00:00:00-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&via=evtnow&url=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.themesatribune.com/tncms/asset/editorial/1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Mesa%20Tribune%5D%20Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&body=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-a8762f44-6b81-11ed-9d9a-a32c13cda117" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-a8762f44-6b81-11ed-9d9a-a32c13cda117" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1268">
            <meta itemprop="height" content="818">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1200%2C774">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1200%2C774"><img
                        src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=400%2C258"
                        srcset="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=150%2C97 150w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=200%2C129 200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=225%2C145 225w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=300%2C194 300w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=400%2C258 400w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=540%2C348 540w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=640%2C413 640w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=750%2C484 750w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=990%2C639 990w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1035%2C668 1035w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1200%2C774 1200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/assets/v3/editorial/a/87/a8762f44-6b81-11ed-9d9a-a32c13cda117/637ea491d192e.image.jpg?resize=1268%2C818 1333w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="1268"
                        height="818"
                        alt="Nathaniel Ross"
                        class="img-responsive full tnt-restrict-img-a8762f44-6b81-11ed-9d9a-a32c13cda117 default" />
            </div><style>
                .tnt-restrict-img-a8762f44-6b81-11ed-9d9a-a32c13cda117 {
                    max-width: 940px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="1ccedaf4-6b81-11ed-a47b-db3e760f6176">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&via=evtnow&url=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.themesatribune.com/tncms/asset/editorial/1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Mesa%20Tribune%5D%20Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&body=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html', '[data-copy-inline-top-1ccedaf4-6b81-11ed-a47b-db3e760f6176]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-top-1ccedaf4-6b81-11ed-a47b-db3e760f6176
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-1ccedaf4-6b81-11ed-a47b-db3e760f6176-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="1ccedaf4-6b81-11ed-a47b-db3e760f6176" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="save-list-1ccedaf4-6b81-11ed-a47b-db3e760f6176-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="1ccedaf4-6b81-11ed-a47b-db3e760f6176" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p class="p1">Nathaniel Ross won’t be sitting on Mesa City Council when new members are sworn next month.</p><p class="p1">But he might have the better deal as he heads next year as a prestigious Rhodes Scholar with a full-ride scholarship to one of the world’s oldest universities.</p><p class="p1">Ross, an Arizona State University senior who unsuccessfully challenged Vice Mayor Jenn Duff in the August Primary Election, earned a coveted Rhodes Scholarship to pursue postgraduate studies at the University of Oxford in London.</p><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.themesatribune.com",
  secureDomain: "www.themesatribune.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":"eastvalleytribune.com","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/community","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-2585773" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585773" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585773');
                        
                });
            </script>
        </div>
    </div>
</div></div><p class="p1">He is one of only 32 American Rhodes recipients for 2023 and one of only three students from a public university.</p><p class="p1">He also is the first ASU student awarded an American Rhodes Scholarship in nearly 20 years.<span class="Apple-converted-space"> </span></p><p class="p1">The most recent ASU student to earn the scholarship was music education major Philip Mann in 2001. He is now on the faculty of the University of Maryland-Baltimore County.</p><p class="p1">“I am incredibly grateful to have been selected,” Ross said. “The finalists in my district were all so incredibly kind and impressive in their own right. Being selected among them was an absolute honor. I am beyond excited to be part of the Rhodes community and study at Oxford next year.”</p><p class="p1">Rhodes Scholarships provide all expenses for two or three years of postgraduate study and were created in 1902 by the will of mining magnate Cecil Rhodes and now supported by various<span class="Apple-converted-space"> </span> philanthropies and benefactors.</p><p class="p1">At Oxford, Ross will study comparative social policy, after which he will attend law school and specialize in disability law.<span class="Apple-converted-space"> </span></p><p class="p1">His long-term objective is to shape disability policy as an attorney-advisor for a national disability advocacy organization, federal agency, or global non-governmental organization.</p><p class="p1">“Arizona State University empowers elite scholars who want to have a meaningful social impact,” said ASU President Michael M. Crow.<span class="Apple-converted-space"> </span></p><p class="p1">“Nathaniel Ross is a uniquely gifted thinker capable of simultaneously synthesizing ideas across diverse subjects and applying his knowledge to improve the lives of others. As such, Nathaniel embodies our highest aspirations as a national service university.”</p><p class="p1">He’s no slouch at ASU either.<span class="Apple-converted-space"> </span></p><p class="p1">A winner of a prestigious Flinn Scholarship, Ross, 21, is graduating next month from Barrett, The Honors College with bachelor’s degrees in biology, history, political science, and applied quantitative science next month. In May, he will be awarded a master’s of science degree in<span class="Apple-converted-space"> </span> biology and society.<span class="Apple-converted-space"> </span></p><p class="p1">A fourth generation Mesa resident, Ross acknowledges the role his time at ASU has played in his success.</p><p class="p1">“I don’t believe there is a single Rhodes scholar that accomplished the feat without a community of support,” he said, “and I am no exception.”</p><p class="p1">He also is excited about the opportunity the Rhodes Scholarship presents.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":"eastvalleytribune.com","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/community","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-2585776" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585776" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585776');
                        
                });
            </script>
        </div>
    </div>
</div></div><p class="p1">“As part of the Rhodes community, I know I can have an even greater impact on the issues I care about. The fraction of Rhodes scholars who are disabled, attend a state school, or are first-generation university students is rather small.<span class="Apple-converted-space"> </span></p><p class="p1">“After my selection, I hope to encourage other people from similar backgrounds to apply for nationally competitive scholarships.”</p><p class="p1">The application process for the Rhodes Scholarship is arduous, and competition is intense, university officials noted.<span class="Apple-converted-space"> </span></p><p class="p1">In his will, Cecil Rhodes stipulated several criteria for the selection of Scholars, most of which are still applied today.</p><p class="p1">“The first and most obvious criterion is ‘scholarly attainment,’” said Kyle Mox, Associate Dean for National Scholarships and ASU representative for the Rhodes Scholarship. “To be competitive, an applicant must have posted near-perfect grades while completing an exceptionally challenging curriculum.”</p><p class="p1">Ross clearly fits the bill, given his multiple degrees and the fact he never had a grade lower than “A,” according to ASU.</p><p class="p1">“But, per Rhodes’s stipulations, Rhodes Scholars are not “mere bookworms” – they must also demonstrate devotion to enacting lasting social impact and be committed to making a strong difference for good in the world, Mox said, explaining:</p><p class="p1">“We often refer to this quality as ‘fighting the world’s fight.’ Rhodes Scholars must show extraordinary leadership potential.”</p><p class="p1">In 2021, Ross was selected as a Udall Scholar for his commitment to environmental and disability activism, and in the spring of 2022, he was selected as national finalist for the Truman Scholarship in recognition of his devotion to public service.</p><p class="p1">A committed disability rights activist, Ross founded EosFighter Connection, a nationwide support network for youth who suffer from eosinophilic and other disorders. He also is politically active, having interned with progressive lobbying firm Creosote Partners.<span class="Apple-converted-space"> </span></p><p class="p1">Ross said the announcement of his selection came as a shock.<span class="Apple-converted-space"> </span></p><p class="p1">“I honestly was not sure if I heard my name correctly,” he said. “Even days later, I don’t think I have even begun to process what this means for my future. All I could think about was the years of work that went into this moment.<span class="Apple-converted-space"> </span></p><p class="p1">“Although applications only opened up this summer, the process of becoming a Rhodes Scholar often begins during freshman year or even earlier.”</p><p class="p1">The Rhodes Trust pays all college and university fees, provides a stipend to cover expenses while in residence in Oxford as well as during vacations, and transportation to and from England. The total value of the scholarship averages approximately $75,000 per year.</p><p class="p1">Now that the process is finished, Ross will begin planning for his journey to England and his studies at Oxford.</p><p class="p1">“I have never been to the UK, and now I will spend the next two to three years of my life studying at the top university in the world. For the first time in my life, moving to another country is a reality for me. I have realized that this homegrown East Valley boy is going to have to buy his first real winter coat to survive the UK winters.”</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":"eastvalleytribune.com","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/www.themesatribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/community","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-2585779" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585779" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585779');
                        
                });
            </script>
        </div>
    </div>
</div></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&via=evtnow&url=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.themesatribune.com/tncms/asset/editorial/1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Mesa%20Tribune%5D%20Who%20needs%20Mesa%20Council%20when%20you%E2%80%99re%20a%20Rhodes%20Scholar%3F&body=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1ccedaf4-6b81-11ed-a47b-db3e760f6176"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.themesatribune.com/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html', '[data-copy-inline-1ccedaf4-6b81-11ed-a47b-db3e760f6176]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-1ccedaf4-6b81-11ed-a47b-db3e760f6176
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-1ccedaf4-6b81-11ed-a47b-db3e760f6176-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="1ccedaf4-6b81-11ed-a47b-db3e760f6176" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="1ccedaf4-6b81-11ed-a47b-db3e760f6176" class="save-list-1ccedaf4-6b81-11ed-a47b-db3e760f6176-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="1ccedaf4-6b81-11ed-a47b-db3e760f6176" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22nathaniel%20ross%22#tncms-source=keyword" class="tag-nathaniel-ross label label-default"  rel="nofollow">Nathaniel Ross</a>
                </li> <li>
                    <a href="/search/?k=%22mesa%20city%20council%22#tncms-source=keyword" class="tag-mesa-city-council label label-default"  rel="nofollow">Mesa City Council</a>
                </li> <li>
                    <a href="/search/?k=%22rhodes%20scholar%22#tncms-source=keyword" class="tag-rhodes-scholar label label-default"  rel="nofollow">Rhodes Scholar</a>
                </li> <li>
                    <a href="/search/?k=%22university%20of%20oxford%22#tncms-source=keyword" class="tag-university-of-oxford label label-default"  rel="nofollow">University Of Oxford</a>
                </li> <li>
                    <a href="/search/?k=%22full-ride%20scholarship%22#tncms-source=keyword" class="tag-full-ride-scholarship label label-default"  rel="nofollow">Full-ride Scholarship</a>
                </li> </ul>
                        </div>
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as anonymous</span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="1ccedaf4-6b81-11ed-a47b-db3e760f6176" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username">anonymous</strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/community/who-needs-mesa-council-when-you-re-a-rhodes-scholar/article_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="1ccedaf4-6b81-11ed-a47b-db3e760f6176" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.themesatribune.com/users/login/?referer_url=https%3A%2F%2Fwww.themesatribune.com%2Fcommunity%2Fwho-needs-mesa-council-when-you-re-a-rhodes-scholar%2Farticle_1ccedaf4-6b81-11ed-a47b-db3e760f6176.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1941998" class="tncms-block"><h3>The Mesa Tribune Northeast</h3>
<iframe id="bloxFrame" src="https://static.issuu.com/widgets/shelf/index.html?folderId=49dec21f-6500-40a6-9274-118f353b6258&amp;theme=theme3&amp;rows=1&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=true&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true" name="bloxFrame" width="100%" height="200px" frameborder="0" scrolling="auto">
</iframe>
<h3>The Mesa Tribune Southeast</h3>
<iframe id="bloxFrame" src="https://static.issuu.com/widgets/shelf/index.html?folderId=91a50021-6043-4999-bacc-23c36c871fd1&amp;theme=theme3&amp;rows=1&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=true&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true" name="bloxFrame" width="100%" height="200px" frameborder="0" scrolling="auto">
</iframe></div><div id="tncms-block-2585758" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585758" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585758');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2532391" class="tncms-block"><script defer src="https://www.voqally.com/hub/app/r.js?key=71fc9ffa5d2b4c78f79cbdcf44167b44"></script></div><div id="tncms-block-2585761" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585761" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585761');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1941997" class="tncms-block"><center><div class="fb-page" data-href="https://www.facebook.com/MesaTribune/" data-tabs="timeline" data-width="400" data-height="800" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/MesaTribune/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/MesaTribune/">The Mesa Tribune</a></blockquote></div></center>
<br>
<br></div><div id="tncms-block-2585764" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585764" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585764');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2645229" class="tncms-block"><a class="twitter-timeline" data-height="400" href="https://twitter.com/EVTNow?ref_src=twsrc%5Etfw">Tweets by EVTNow</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<br></div><div id="tncms-block-2585767" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585767" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585767');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-2585755" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2585755" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2585755');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1911936" class="tncms-block"><section id="block-1911936" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1911936 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link   nav-home  tnt-section-home"  href="/"  tabindex="0" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only">Home</span>
                </a></li><li>
                <a class="nav-link    tnt-section-news"  href="/news/"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-community"  href="/community/"  tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business"  href="/business/"  tabindex="0" >
                    <span class="nav-label ">Business</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-get-out"  href="/get_out/"  tabindex="0" >
                    <span class="nav-label ">Get Out</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-obits"  href="/obits/"  tabindex="0" >
                    <span class="nav-label ">Obits</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1911928" class="tncms-block"><section id="block-1911928" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1911928 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-about"  href="https://www.themesatribune.com/site/about.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">About</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="https://www.themesatribune.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Contact</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="https://www.themesatribune.com/site/forms/online_services/advertise_with_us/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-employment"  href="http://timespublications.com/#careers"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Employment</span>
                </a></li><li>
                <a class="nav-link    tnt-section-classifieds"  href="https://www.eastvalleytribune.com/classifieds/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Classifieds</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Local Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=EASTVALLEYTRIBUNE&amp;publisher_url:eastvalleytribune.com#/quick"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link    tnt-section-terms-of-service"  href="/site/terms.html"  tabindex="0" >
                    <span class="nav-label ">Terms of Service</span>
                </a></li><li>
                <a class="nav-link    tnt-section-privacy-policy"  href="/site/privacy.html"  tabindex="0" >
                    <span class="nav-label ">Privacy Policy</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1911940" class="tncms-block padding-bottom"><section id="block-1911940" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/09a011a0-3587-11eb-b635-b3a7790d67cd.png?resize=150%2C48 150w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/09a011a0-3587-11eb-b635-b3a7790d67cd.png?resize=200%2C64 200w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/09a011a0-3587-11eb-b635-b3a7790d67cd.png?resize=225%2C72 225w, https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/content/tncms/custom/image/09a011a0-3587-11eb-b635-b3a7790d67cd.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="96"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-1911938" class="tncms-block"><section id="block-1911938" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1911938 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>TheMesaTribune.com</strong><br>
    1900 W. Broadway<br>
    Tempe, AZ 85202
    <br>
    
        <strong>Phone:</strong> 480-898-6500<br>
        <strong>Email:</strong> <a href="mailto:info@themesatribune.com">info@themesatribune.com</a><br>
    
</address></section></div><div id="tncms-block-1911944" class="tncms-block padding-bottom"><div class="follow-links-1911944 follow-links default">
    
    <section id="block-1911944" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1911944 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/EVTNow/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/evtnow" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.themesatribune.com",
  "sameAs" : ["https://www.facebook.com/EVTNow/","https://twitter.com/evtnow"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1911929" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1911929"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">The Mesa Tribune</a>, 1900 W. Broadway Tempe, AZ</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("1ccedaf4-6b81-11ed-a47b-db3e760f6176")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["community"],
            'tncms.asset.flags': ["top_story"],
            'tncms.asset.keywords': ["nathaniel ross", "mesa city council", "rhodes scholar", "university of oxford", "full-ride scholarship"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/www.themesatribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1911941'),
            query_input = d.getElementById('site-search-1911941-term'),
            search_dropdown = d.getElementById('site-search-1911941-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1911941 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1911947').click(function(e){
                                        $('#weather-1911947 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1911942'),
            query_input = d.getElementById('site-search-1911942-term'),
            search_dropdown = d.getElementById('site-search-1911942-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1911942 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ 
                    /* Copy url to clipboard */
                    function copyLink(url, copyTarget) {
                        /* Populate clipboard */
                        navigator.clipboard.writeText(url);
                        
                        /* Bootstrap popover */
                         $(copyTarget).popover().popover("show").prop("disabled", true);
                        
                        /* Hide popover after timeout */
                        setTimeout(
                            function() {
                               $(copyTarget).popover("hide").popover("destroy").prop("disabled", false);
                            }, 2000);
                    } /*]]>*/</script></body>
</html>